Service Hotline Urgent Maintenance
Incident Report for LayerStack
Resolved
The maintenance was completed at 13:00 (GMT +8).
Posted over 1 year ago. May 16, 2018 - 13:08 HKT
Investigating
Our system engineer team is working the urgent maintenance for phone system, and should resume service hotline immediately once the maintenance task has been completed.

Customer can use "Live Chat" channel to contact our helpdesk representative by clicking following URL if need assistance.
https://www.layerstack.com/livechat

We sincerely apologize for any inconvenience that might cause to you.
Posted over 1 year ago. May 16, 2018 - 12:10 HKT